package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^x{3}y{3}$`)
var str = `xxxyyy`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}