# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
(?(DEFINE)
(?<currency_symbol> \p{Sc} )
(?<leading_group> [1-9] \d{0,2}+ )
(?<group> \d{3} )
(?<non_leading_groups> (?&group) (?:(?&group_delim)(?&group))*+ )
(?<decimal_delim>
(?# Use the opposite of group_delim. )
(?(group_delim_comma)
\.
| (?(group_delim_period)
,
| [,.] (?# There's no definitive grouping_delim. )
)
)
)
)
^
(?>
(?¤cy_symbol)
(?&leading_group)
(?:
(?<group_delim>
(?<group_delim_comma> , ) |
(?<group_delim_period> \. ) |
\ (?# Allow whitespace as a delimiter. )
)
(?&non_leading_groups)
| \d*+ (?# It's also possible that there's no delimiter. )
)
)
(?:
(?&decimal_delim)
\d*+
)?+
$
"""
test_str = ("We want to match these:\n"
"$1\n"
"$10\n"
"$100\n"
"$1000\n"
"$1,000\n"
"$10,000\n"
"$100,000\n"
"$1,000,000\n"
"$1.00\n"
"$100.00\n"
"$10,000.00\n"
"$1,000,000.00\n"
"$1.000.000,00\n"
"$1.000\n"
"$1.000.000\n"
"$1,00\n"
"$1.000,00\n"
"$10000000000000\n\n"
"We don't want to match these:\n"
"$1,000,00\n"
"$1,00,00\n"
"$1.00.000\n\n"
"A few different currency symbols that we want to match:\n"
"$1\n"
"¢1\n"
"£1\n"
"¤1\n"
"¥1\n"
"₠1\n"
"₡1\n"
"₢1\n"
"₣1\n"
"₤1\n"
"₥1\n"
"₦1\n"
"₧1\n"
"₩1\n"
"₪1\n"
"₫1\n"
"€1\n"
"₭1\n"
"₮1\n"
"₯1\n"
"₰1\n"
"₱1\n"
"₲1\n"
"₳1\n"
"₴1\n"
"₵1\n"
"₶1\n"
"₷1\n"
"₸1\n"
"₹1\n"
"₺1\n"
"₻1\n"
"₼1\n"
"₽1\n\n"
"Nearby symbols that share some bytes (UTF-8) that we don't want to match:\n"
"¡1\n"
"¦1\n"
"§1\n"
"©1\n"
"ₔ1")
matches = re.finditer(regex, test_str, re.UNICODE | re.VERBOSE | re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.