import re
regex = re.compile(r"(?<=says\sto)[\s\S]*?(?=\(\d{4}-\d{2}-\d{2}\s(\d\d:){2}\d{2}\s\w{2}\s\w{3}\))", flags=re.MULTILINE)
test_str = ("(2021-07-04 11:58:43 PM BST) \n"
"--- \n"
"len wee zim (Tradition (US) ) says to yohan sen \n"
"[[:Conversations will be recorded and may be monitored by the participants and\n"
"their employers:]] Hi yohan \n"
" \n"
" \n\n"
"(2021-07-05 12:04:42 AM BST) \n"
"--- \n"
"len wee zim (Tradition (US) ) says to yohan sen \n"
"okay -5 / 0 .\n\n\n\n"
"(2021-07-04 11:47:14 PM BST) \n"
"--- \n"
"Ke Cho Ki says to\n"
"Hano Cho \n"
"hello \n"
" \n\n"
"(2021-07-05 12:09:41 AM BST) \n"
"--- \n"
"len wee zim (Tradition (Asia)) says \n"
"to yohan sen \n"
"yes -5 / 0 TN -- / +2.5 \n"
" \n"
" \n"
"--- \n"
" \n"
"* * *\n\n"
"Processed by wokl Archive for son malab | 2021-07-05 12:26:44 AM\n"
"BST \n"
"---")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)