$re = '/(?<=^|,)4(?=$|,)/m';
$str = '4,44,24
44,4,24
4
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);