import re
regex = re.compile(r"(head|director|vp|vice[- ]president|chief)\s*(of\s*)?(growth|marketing)|cmo|chief marketing officer|C(ief )?R(evenue )?O(fficer)?\b", flags=re.IGNORECASE | re.MULTILINE)
test_str = (" \"Revenue Ops Manager\",\n"
" \"Growth Marketing Manager\",\n"
" \"CEO\",\n"
" \"Director of Operations\",\n"
" \"Sales Ops Analyst\",\n"
" \"VP of Sales\",\n"
" \"Marketing Operations Specialist\",\n"
" \"Lead Generation Manager\",\n"
" \"Product Ops Director\",\n"
" \"GTM Strategy Lead\",\n"
" \"Head of Growth\",\n"
" \"Chief Marketing Officer\",\n"
" \"Director of Business Development\",\n"
" \"Junior Revenue Analyst\",\n"
" \"Freelance Growth Consultant\",\n"
" \"CTO and Product Owner\",\n"
" \"Sales Development Representative\",\n"
" \"Intern Marketing Operations\",\n"
" \"Business Systems Administrator\",\n"
" \"Country Manager and COO\",\n"
" \"Chief Growth Officer\",\n"
" \"VP Marketing and Communications\",\n"
" \"Head of Business Opportunities\",\n"
" \"Revenue Operations Specialist\",\n"
" \"Product Marketing Manager\"\n"
"Revenue Ops\n"
"RevOps\n"
"Chief Revenue Officer\n"
"CRO\n"
"CMO")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")