re = /^((([1][9][0|2|4|6|8][0|4|8]|[1][9][1|3|5|7|9][2|6]|[2][0][0][0|4|8]|[2][0][1][2])[-|\\|\/|\.]([1][1-2]|[0][1|3|5|7|8])[-|\\|\/|\.]([0][1-9]|[1][0-9]|[2][0-9]|[3][0-1])|([1][9][0|2|4|6|8][0|4|8]|[1][9][1|3|5|7|9][2|6]|[2][0][0][0|4|8]|[2][0][1][2])[-|\\|\/|\.][0][2][-|\\|\/|\.]([0][1-9]|[1][0-9]|[2][0-9])|([1][9][0|2|4|6|8][0|4|8]|[1][9][1|3|5|7|9][2|6]|[2][0][0][0|4|8]|[2][0][1][2])[-|\\|\/|\.]([1][1]|[0][4|6|9])[-|\\|\/|\.]([0][1-9]|[1][0-9]|[2][0-9]|[2][0]))|(([1][9][0|2|4|6|8][1|2|3|5|6|7|9]|[1][9][1|3|5|7|9][0|1|3|4|5|7|8|9]|[2][0][0][1|2|3|5|6|7|9]|[2][0][1][0|1|3])[-|\\|\/|\.]([1][1-2]|[0][1|3|5|7|8])[-|\\|\/|\.]([0][1-9]|[1][0-9]|[2][0-9]|[3][0-1])|([1][9][0|2|4|6|8][1|2|3|5|6|7|9]|[1][9][1|3|5|7|9][0|1|3|4|5|7|8|9]|[2][0][0][1|2|3|5|6|7|9]|[2][0][1][0|1|3])[-|\\|\/|\.][0][2][-|\\|\/|\.]([0][1-9]|[1][0-9]|[2][0-8])|([1][9][0|2|4|6|8][1|2|3|5|6|7|9]|[1][9][1|3|5|7|9][0|1|3|4|5|7|8|9]|[2][0][0][1|2|3|5|6|7|9]|[2][0][1][0|1|3])[-|\\|\/|\.]([1][1]|[0][4|6|9])[-|\\|\/|\.]([0][1-9]|[1][0-9]|[2][0-9]|[2][0])))$/
str = '2012-02-29'
# Print the match result
str.match(re) do |match|
puts match.to_s
end