$re = '/(.*)<(.*)\|(.*)>(.*)/';
$str = 'I <not ride|do not ride> horses';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);