$re = '/^(?:0|00)\d+$/m';
$str = '0123
001212
1212';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;