$re = '/^0{1,2}\d+$/m';
$str = '0shj
08989
008787
';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;