re = /(_\d+(?:,\d+)*)/m
str = 'Lorem ipsum dolor sit amet, consectetur adipiscing elit. _4,7,13 Nullam suscipit orci sit amet feugiat facilisis. Curabitur eget 8 ligula malesuada, vehicula 3,6 quam sit amet, _5 tempor velit.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end