$re = '/-(?=\d+%)/m';
$str = 'About -38% is made with this-and also with something else.';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;