package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`html_log:(?P<name>[^ ]*)(?: [^\s]+){4} (?P<score>[^ ]*)`)
var str = `html_log:jeff 1153.3 1.84 625:54 1 2 71 3 2 10 7:58 499 3 5 616:36 241 36 html_log:fred 28.7 1.04 27:34 -10 18 13 0:48 37 18 8 -3.63 html_log:bob 1217.1 1.75 696:48 1 5 38 6 109 61 14:42 633 223 25 435:36 182 34`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}