#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(#endif\W+){1}$"
Local $sString = "test" & @CRLF & _
"#endif" & @CRLF & _
"" & @CRLF & _
"void func()" & @CRLF & _
"{" & @CRLF & _
"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")