package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\w+)\/N`)
var str = `I am Duc/N Ta/N Van/N`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}