package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`{{\$([^}]+)}}`)
var str = `{{$testa.testb.testc}}<br>{{$testc.testa}}<br>{{$testf}}<br>{{$aaaaa}}<br>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}