#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "translate\(\'([^)]*)\',"
Local $sString = "<div class="row">" & @CRLF & _
" <div class="col-md-12">" & @CRLF & _
" <div class="content-title"><?php echo $this->translate('Contattaci'); ?></div>" & @CRLF & _
"" & @CRLF & _
" <?php if ( $this->messageProcessed && $this->sendError ): ?>" & @CRLF & _
" <div class="alert alert-danger">" & @CRLF & _
" <h4><span class="glyphicon glyphicon-exclamation-sign"></span> <?php echo $this->translate('Errore Invio Messaggio'); ?></h4>" & @CRLF & _
" <?php echo $this->translate('Spiacenti, si é verificato un errore durante l’invio del messaggio'); ?>." & @CRLF & _
" <p class="error"><?php echo $this->sendError; ?></p>" & @CRLF & _
" </div>" & @CRLF & _
" <?php elseif ( $this->messageProcessed & !$this->sendError ): ?>" & @CRLF & _
" <div class="alert alert-success">" & @CRLF & _
" <h4><span class="glyphicon glyphicon-ok-circle"></span> <?php echo $this->translate('Messaggio Inviato'); ?></h4>" & @CRLF & _
" <?php echo $this->translate('Grazie per il tuo messaggio. Risponderemo nel piú breve tempo possibile'); ?>." & @CRLF & _
" </div>" & @CRLF & _
" <?php else: ?>" & @CRLF & _
" <div class="well well-sm">" & @CRLF & _
" <?php echo $this->translate('Compila il modulo seguente per inviarci un tuo messaggio.'); ?><br />" & @CRLF & _
" <?php echo $this->translate('Sarà nostra premura rispondere nel minor tempo possibile per fornirti tutte le informazioni di cui puoi necessitare.'); ?>" & @CRLF & _
" </div>" & @CRLF & _
" <?php if ( $this->getSetting('site_phone') ): ?>" & @CRLF & _
" <div class="alert alert-info alert-dismissable">" & @CRLF & _
" <button aria-hidden="true" data-dismiss="alert" class="close" type="button">×</button>" & @CRLF & _
" <span class="glyphicon glyphicon-info-sign"></span> <?php echo $this->translate('Se preferisci, puoi contattarci telefonicamente al numero <b>%s</b>', $this->getSetting('site_phone')); ?>" & @CRLF & _
" </div>" & @CRLF & _
" <?php endif; ?>" & @CRLF & _
" <div class="contact-form">" & @CRLF & _
" <?php echo $this->form; ?>" & @CRLF & _
" <div class="clearfix"></div>" & @CRLF & _
" <p> </p>" & @CRLF & _
" <div class="small text-justify well well-sm">" & @CRLF & _
" <?php echo $this->translate('I dati personali saranno trattati ai sensi del D.Lgs. 196/2003, sulla tutela delle persone e di altri soggetti rispetto al trattamento dei dati personali, il trattamento delle informazioni che ti riguardano, sarà improntato ai principi di correttezza, liceità e trasparenza e tutelando la tua riservatezza e i tuoi diritti.'); ?>" & @CRLF & _
" </div>" & @CRLF & _
" </div>" & @CRLF & _
" <?php endif; ?>" & @CRLF & _
" </div>" & @CRLF & _
"</div>" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")