re = /(?<![a-z])(?:(?![aeiou]{2}|[^\P{L}aeiou]{2})[a-z])+(?![a-z])/i
str = 'Dog,cat,mouse,bird.Human.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end