$re = '/^(:?(?=[1])(10{0,8})|(?=[^0])(\d{1,8})|0)\.[0-9]{1,2}$/m';
$str = '0.232
00.32
0.00
0.98
0000.23
012.12
100000000.00
900000000.00
100000990.00
10000990.00
1000990.00
100990.00
99999999.00
99999990.00
99999991.00
99999992.00
99999993.00
99999994.00
99999995.00
99999996.00
99999997.00
99999998.00
10876682.00
83957370.00
32276025.00
59955781.00
23643169.00
73365781.00
68940216.00
27380481.00
85310811.00
32140789.00
70892466.00
92364715.00
82507898.00
46090208.00
53708181.00
4048315.00
97224300.00
10173228.00
21249514.00
84097086.00
72406479.00
99146513.00
82654346.00
45603833.00
39643534.00
57667203.00
3051654.00
8585918.00
10899673.00
82252655.00
36847069.00
86911549.00
49905120.00
86506643.00
16105612.00
42483976.00
92170115.00
56836463.00
76841977.00
10424761.00
20884622.00
16893907.00
98519645.00
2948879.00
59347569.00
63834451.00
2567857.00
37988959.00
18609517.00
20113192.00
2075478.00
96205131.00
69710650.00
28645516.00
84107268.00
61884055.00
36015436.00
42563311.00
58635986.00
2480793.00
74336882.00
41176173.00
18413160.00
59682321.00
57191890.00
96251834.00
60030968.00
61135387.00
70065230.00
13392581.00
8390468.00
55089191.00
78776612.00
17223059.00
40920281.00
6370210.00
82946642.00
38724305.00
80767575.00
99605287.00
80873099.00
92898664.00
87100823.00
82275846.00
45803611.00
49676857.00
75586944.00
94267999.00
30316905.00
58347072.00
75753796.00
20573919.00
68927953.00
94569041.00
24118004.00
88094098.00
17457549.00
26246739.00
64392494.00
47575569.00
36150252.00
7189770.00
4100094.00
44339675.00
59582445.00
85882613.00
11256804.00
22164436.00
55920337.00
77480391.00
31585441.00
12774414.00
97551568.00
76149074.00
47080480.00
88334504.00
98491905.00
68809287.00
16324716.00
93007076.00
33258751.00
35125683.00
24130884.00
4169724.00
6232620.00
49965044.00
67417304.00
58001706.00
77518603.00
89975499.00
54390329.00
74155453.00
74152020.00
85448980.00
19690408.00
32537849.00
33432378.00
49452932.00
64541244.00
43688527.00
61373648.00
97445528.00
62232537.00
72155701.00
36035525.00
52292502.00
31519032.00
95036698.00
50082726.00
17168560.00
13804004.00
86670409.00
26730756.00
42631779.00
69106192.00
27412319.00
98836485.00
64170204.00
32950034.00
27440528.00
89173744.00
15759012.00
22807330.00
62047566.00
80681976.00
30695391.00
23060620.00
48895232.00
31187105.00
46121072.00
6713583.00
5040902.00
28303696.00
46404298.00
26638547.00
2632008.00
77803663.00
1127277.00
49906626.00
56716909.00
83704608.00
94019930.00
96370292.00
20567511.00
71413066.00
62390219.00
87354858.00
57632918.00
47761130.00
40375913.00
85327514.00
67332855.00
24419284.00
76857108.00
9452588.00
86339492.00
33215813.00
51064623.00
88852647.00
58800062.00
35204524.00
79816762.00
28575775.00
82306828.00
64736081.00
92197121.00
52996961.00
87654013.00
90155925.00
15699646.00
37566846.00
21278873.00
27829169.00
51044551.00
55393256.00
18921606.00
83983323.00
37809212.00
38135789.00
676063.00
65129782.00
19017803.00
16921494.00
40387770.00
1667106.00
58645222.00
93070856.00
57010047.00
38230631.00
8205896.00
80452382.00
42619255.00
60752131.00
80837257.00
51726117.00
27463823.00
39153162.00
56131179.00
42914321.00
29580329.00
59373791.00
16076937.00
63591253.00
92918539.00
52524071.00
57775194.00
79795388.00
91174373.00
84693483.00
1549640.00
59424135.00
19180100.00
17529692.00
9623172.00
7862381.00
87895427.00
67988490.00
84750839.00
43167018.00
25530866.00
23047845.00
36672140.00
34038375.00
16956096.00
22233841.00
9882482.00
58257233.00
35663170.00
96704336.00
42722991.00
30764462.00
2931045.00
84423880.00
58675904.00
3144857.00
45479805.00
97196383.00
11729991.00
83763812.00
93982824.00
11922642.00
23884299.00
88682766.00
96970396.00
99825892.00
25412354.00
68436242.00
56303289.00
6993701.00
9013235.00
94603890.00
84352437.00
53991118.00
60982535.00
15152347.00
5537021.00
84915341.00
96637202.00
42526785.00
85876786.00
97687253.00
11074340.00
71804274.00
13703272.00
2567952.00
27131241.00
96056135.00
92132319.00
62383529.00
50443727.00
53046068.00
46979522.00
77572492.00
56237806.00
40889696.00
56635158.00
45425586.00
20872608.00
63733132.00
39126911.00
82998612.00
24472118.00
1531625.00
90847589.00
57342652.00
10489844.00
35438548.00
17948065.00
79492930.00
35766008.00
10017475.00
5761735.00
71826666.00
15492970.00
80675589.00
92698101.00
75309981.00
48236099.00
90884978.00
58529637.00
17480652.00
3474128.00
31454876.00
59919674.00
68221113.00
59342936.00
44183761.00
57363319.00
6797423.00
85021527.00
33157638.00
71046224.00
43466195.00
84325310.00
43568510.00
93824989.00
62815709.00
91698514.00
34562699.00
68698266.00
91646361.00
81367895.00
36287524.00
6250205.00
36970098.00
7023234.00
35793876.00
9340146.00
25134172.00
37827444.00
93882132.00
90016962.00
14830411.00
94538263.00
15164674.00
29530713.00
56071211.00
22929785.00
81832529.00
34075558.00
1277654.00
93815353.00
21869123.00
57517278.00
96702004.00
84501360.00
29334992.00
53856206.00
34402759.00
28183024.00
31205388.00
83603291.00
78633579.00
66179587.00
85102505.00
43021394.00
60969447.00
7776528.00
35404950.00
96614203.00
63070728.00
7478374.00
80161809.00
30138416.00
26367729.00
21144833.00
55597862.00
17256275.00
8026348.00
13708754.00
98170739.00
11455012.00
6141703.00
95128658.00
26690064.00
9528113.00
1541731.00
62972948.00
6893394.00
67971647.00
77646374.00
1525184.00
19289820.00
73174085.00
86674391.00
60728894.00
42728059.00
7033290.00
30113129.00
53845760.00
460842.00
21378536.00
86243397.00
33108412.00
20587516.00
32038845.00
76171743.00
76248346.00
58558695.00
43726924.00
34850203.00
72701918.00
36165150.00
65741731.00
10844959.00
58818298.00
29954415.00
47201209.00
91065741.00
84649957.00
38125169.00
60123060.00
49673923.00
83684624.00
91785793.00
24085149.00
50756657.00
74024582.00
47881166.00
13265039.00
54853248.00
37776838.00
32518520.00
13855357.00
84354822.00
42069875.00
33024981.00
97439357.00
12229957.00
78662475.00
19912717.00
90606310.00
46002428.00
42109731.00
38668087.00
6828287.00
67855071.00
9488825.00
39613135.00
85408810.00
76816949.00
58333578.00
49786329.00
2910108.00
20333294.00
53028092.00
37199751.00
1359517.00
23854322.00
22191799.00
64707087.00
85152450.00
99187999.00
38028826.00
2434502.00
89898643.00
26376623.00
33751068.00
40025841.00
31221169.00
47479304.00
73751251.00
29576333.00
26584960.00
43655896.00
38471734.00
76822778.00
28542996.00
22674558.00
57727490.00
12802916.00
3500766.00
41838130.00
50969831.00
46481228.00
1792920.00
50489570.00
16438975.00
22905113.00
66240921.00
4782224.00
63575741.00
44334881.00
27559040.00
50315799.00
30371484.00
69134379.00
10571522.00
93946339.00
79304180.00
76216094.00
63352727.00
31434010.00
82646787.00
59205406.00
73513313.00
21669203.00
26063408.00
59283755.00
68191913.00
43535188.00
20646010.00
35940240.00
26174083.00
82173537.00
22235558.00
62053415.00
50603476.00
92918033.00
82988283.00
45081567.00
80808808.00
98204305.00
57047813.00
7602205.00
51457856.00
60756117.00
44675467.00
25904346.00
94222016.00
47262553.00
36194963.00
80828567.00
44412535.00
60663606.00
35989849.00
11028873.00
76096456.00
98140456.00
28583413.00
36115622.00
41567379.00
22193898.00
18552819.00
17599501.00
39355838.00
82493311.00
2563274.00
99992316.00
86327810.00
67779741.00
91526307.00
36530678.00
55397640.00
61283029.00
22868681.00
82399548.00
29520689.00
99115777.00
12506050.00
56987663.00
96021339.00
12683148.00
23986935.00
19389774.00
94402345.00
6838123.00
38383581.00
28554748.00
47377263.00
19397909.00
9795406.00
63275921.00
10081895.00
12502185.00
99160160.00
23166293.00
97853858.00
21461827.00
98136292.00
49615037.00
4471216.00
85005615.00
27734109.00
53473317.00
88053108.00
38500194.00
56876893.00
26880013.00
98486130.00
95378771.00
62746544.00
7702139.00
15778362.00
32743055.00
97219240.00
11065996.00
89484129.00
51286982.00
59172822.00
27903574.00
92991764.00
89542700.00
18788544.00
33775818.00
79939311.00
89504404.00
10270953.00
93183638.00
897567.00
46943004.00
64430658.00
79081777.00
36972923.00
81210096.00
14315443.00
61214263.00
15528038.00
20081870.00
29193406.00
48881051.00
64862212.00
19540258.00
85914193.00
77026862.00
93670294.00
51656276.00
46289249.00
78362841.00
57162001.00
64333689.00
59458691.00
54670761.00
39367975.00
27176980.00
22062554.00
34995679.00
8389521.00
45116095.00
30180890.00
7284118.00
59441099.00
89884341.00
77582893.00
75194986.00
73752663.00
62507383.00
83646993.00
97878949.00
87271996.00
8485823.00
81098714.00
61644178.00
16428594.00
85318980.00
82281502.00
80705845.00
73120058.00
29498530.00
87391528.00
46269511.00
10318143.00
96873996.00
68279036.00
2515321.00
16643542.00
13252833.00
17694748.00
17479906.00
18286342.00
99243553.00
90591924.00
15439280.00
50027310.00
79393253.00
94122081.00
25763315.00
51510878.00
37873060.00
48651155.00
23613409.00
33009895.00
14334514.00
75951001.00
18149897.00
87568612.00
81521934.00
37184103.00
88503933.00
36197099.00
66863679.00
37247458.00
2399583.00
16865334.00
69915570.00
89615312.00
2083265.00
31599981.00
43301039.00
92893370.00
67963599.00
99233991.00
29991417.00
18181890.00
58984313.00
98887844.00
10280993.00
35078159.00
99814967.00
45590788.00
13645730.00
35280225.00
75356103.00
43330912.00
73038639.00
14806101.00
91126698.00
26835137.00
86827154.00
55772129.00
1366407.00
90809055.00
57966715.00
22105974.00
20280301.00
58845933.00
77805346.00
10850223.00
1410917.00
92969781.00
83613197.00
68533811.00
4915171.00
52213066.00
49334815.00
50248779.00
73908805.00
91830522.00
94654525.00
84919685.00
50219525.00
43197557.00
64092147.00
77407058.00
21642423.00
73035503.00
26782806.00
63103548.00
24556139.00
94317.00
311316.00
66520425.00
22817622.00
61445900.00
7968298.00
80026967.00
70289473.00
38082018.00
70268334.00
8224983.00
22484529.00
25877263.00
54543249.00
52928939.00
62646400.00
42581437.00
35465443.00
21950833.00
56673890.00
78338483.00
55480842.00
18615837.00
61477968.00
81609623.00
28236855.00
40842945.00
39790214.00
60140688.00
8052259.00
60419262.00
91400991.00
81775217.00
93773333.00
40828479.00
4329694.00
54206991.00
71464745.00
37580278.00
22048631.00
1502871.00
63701788.00
15952812.00
60894951.00
67918358.00
6000309.00
45787644.00
85524885.00
18449660.00
90481009.00
89549621.00
69890851.00
85466643.00
94964119.00
26972302.00
42503069.00
96887995.00
67952949.00
86309896.00
9697696.00
14507445.00
5416517.00
72908292.00
50209922.00
43750594.00
24515638.00
83530465.00
55635564.00
37295320.00
575702.00
66839403.00
15277343.00
26267375.00
45992131.00
2244230.00
18310891.00
11920970.00
89523597.00
10259548.00
50036941.00
4807745.00
16905812.00
87436771.00
26166717.00
19549690.00
66703500.00
36683786.00
6941651.00
65295768.00
50181755.00
2050613.00
16087935.00
78877462.00
24479898.00
59673337.00
75276806.00
23096633.00
60537608.00
99731008.00
90272452.00
24997763.00
43465899.00
7309540.00
76909812.00
66625395.00
73021196.00
797018.00
74654526.00
3498637.00
94722788.00
63444586.00
54719863.00
57225825.00
75947503.00
43609948.00
18294266.00
68936669.00
31138820.00
55648349.00
67765242.00
86634902.00
39345775.00
73521736.00
19591373.00
39108879.00
60775341.00
52506296.00
80254194.00
99454631.00
39369913.00
42079331.00
28293865.00
33528014.00
74267914.00
211761.00
46124927.00
12673382.00
51129498.00
39151238.00
80596618.00
42569620.00
37230199.00
3318985.00
86362626.00
20032615.00
80936455.00
38284436.00
13950817.00
31108087.00
34186303.00
55525760.00
69352391.00
30979099.00
43527134.00
36758696.00
38568318.00
97835966.00
63431337.00
61785253.00
4633422.00
36421786.00
41199066.00
45953679.00
9943367.00
17060631.00
43141139.00
72978584.00
9631852.00
53263791.00
5920641.00
64409013.00
81966730.00
49940451.00
16024198.00
13843888.00
61852271.00
99084304.00
2302120.00
6309499.00
23313413.00
93707641.00
29632533.00
5311912.00
49252880.00
36264787.00
99649046.00
50997812.00
78509632.00
45576414.00
89312371.00
65537168.00
9771853.00
73396905.00
25312158.00
88650051.00
65868166.00
55961819.00
38922811.00
36512401.00
53044072.00
71276761.00
26514635.00
34527464.00
66115741.00
91355258.00
25385097.00
83991530.00
83530477.00
71675357.00
56054621.00
43511274.00
86663160.00
43948289.00
60764669.00
38017939.00
60546149.00
61608028.00
85239083.00
16002046.00
38624099.00
3566107.00';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);