re = /^Article_[A-Z]{3}_Scout_(?:0[1-9]|[1-2][0-9]|3[01])-(?:0[1-9]|1[012])-(?:[1-9][0-9]|0[1-9])\.pptx/m
str = 'Article_RAR_Scout_13-03-14.pptx'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end