$re = '/([^_]+)_.+_([^_]+)\.jpg/u';
$str = 'one_two_three_important-data.jpg';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);