$re = '/# Only include if previous char was start of string or delimiter
(?<=^|,)
(?:
# 1st option: empty quoted string (,\'\',)
\'{2}
|
# 2nd option: nothing (,,)
(?:)
|
# 3rd option: all but quoted strings (,123,)
# (included linebreaks to allow multiline matching)
[^,\'\r\n]+
|
# 4th option: quoted strings (,\'123\'\'321\',)
# start pling
\'
(?:
# double quote
\'{2}
|
# or anything but quotes
[^\']+
# at least one occurance - greedy
)+
# end pling
\'
)
# Only include if next char is delimiter or end of string
(?=,|$)/xm';
$str = '12,\'\',\',\'\'\',123
123,2.99,AMO024,Title,\'Description, more info\',,123987564';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);