package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\d+)pcs,\s(\d+)\$`)
var str = `300pcs, 200$`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}