import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<script[^>]+>[\\s|\\S]*('facebook-jssdk'\\)\\);\n"
+ "\\/\\/ ]]><\\/script>)";
final String string = "<p><em>ขอขอบคุณข้อมูลจาก <a href=\"https://www.facebook.com/CrewabsCabincrew/photos/a.163266007065328.35057.162290157162913/981295968595657/?type=3\">เฟซบุ๊ก Crewabs Cabincrew</a></em></p>\n"
+ "<script type=\"text/javascript\"></script>asdasd\n"
+ "asdasdasd\n"
+ "asdad\n\n"
+ "<script type=\"text/javascript\">// <![CDATA[\n"
+ "(function(d, s, id) { var js, fjs = d.getElementsByTagName(s)[0]; if (d.getElementById(id)) return; js = d.createElement(s); js.id = id; js.src = \"//connect.facebook.net/th_TH/sdk.js#xfbml=1&version=v2.3\"; fjs.parentNode.insertBefore(js, fjs);}(document, 'script', 'facebook-jssdk'));\n"
+ "// ]]></script>\n"
+ "<div class=\"fb-post\" data-href=\"https://www.facebook.com/CrewabsCabincrew/photos/a.163266007065328.35057.162290157162913/981295968595657/?type=3\" data-width=\"500\">\n"
+ "<div class=\"fb-xfbml-parse-ignore\">\n"
+ "<blockquote cite=\"https://www.facebook.com/CrewabsCabincrew/photos/a.163266007065328.35057.162290157162913/981295968595657/?type=3\">\n"
+ "<p>จากใจแอร์สาวบนไฟล์ทที่โดนหนุ่มรถไฟจีบด้วยมุก\"ระเบิด\"กรณีหนุ่มรถไฟ แซวแอร์ไทยไลอ้อน อยากขอพื้นที่ชี้แจงให้ลูกเรือสาวในไ...</p>\n"
+ "Posted by <a href=\"https://www.facebook.com/CrewabsCabincrew/\">Crewabs Cabincrew</a> on <a href=\"https://www.facebook.com/CrewabsCabincrew/photos/a.163266007065328.35057.162290157162913/981295968595657/?type=3\">3 พฤศจิกายน 2015</a></blockquote>\n"
+ "</div>\n"
+ "</div>\n"
+ "</div>\n"
+ "</div>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}