// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"((\"[^=]*|[\w\.]+)\s*=\s*(\w+|\"[^"]*\"))"#).unwrap();
let string = "KeylessBuy=f and not (Feedback.color = green or comment.color=green)
and not \"BIN State\".color = white and comment=\"got it right\"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}