$re = '/^((?!.*(profile|adverse))[^\/]+)$/';
$str = '5401b864ad2f1';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);