re = /(?=(?<!\w)('|")(?!\s)(?P<content>(.(?!(?<=')(?=\s)))*)\1)/
str = '\'Well, I\'ve tried to say "How Doth the Little Busy Bee," but it all came different!\' Alice replied in a very melancholy voice. She continued, \'I\'ll try again.\''
# Print the match result
str.scan(re) do |match|
puts match.to_s
end