re = /"^(?=.*[A-Za-z])(?=.*\d)(?=.*[@$!%*#?&])[A-Za-z\d@$!%*#?&]{8,}$"/i
str = '....dasd'
# Print the match result
str.match(re) do |match|
puts match.to_s
end