$re = '/^\d{9}-\w*$/m';
$str = '101010101-Teststring';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);