$re = '/(\s?#[a-zA-Z0-9]+,?)+/';
$str = '#tag1, #tag2, #tag3';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);