package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[A-z]*(\s[A-z]*)*`)
var str = `Ajin Cherian jose Martin`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}