re = /^(?!\S*[£%&+¬¦éúíóáÉÚÍÓÁ])(?=\S*[a-z])(?=\S*[A-Z])(?=\S*\d)\S{7,30}$/m
str = '£%&+¬¦éúíóáÉÚÍÓÁaA4
dddddddddd3Addddddddd'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end