re = /((?![.\n\s])[^.\n"]*(?:"[^\n"]*[^\n".]"[^.\n"]*)*(?:"[^"\n]+\."|\.|(?=\n)))/i
str = ' She was reading her little lord a tale of the Winged Knight when Mya Stone came knocking on the door of his bedchamber, clad in boots and riding leathers and smelling strongly of the stable. Mya had straw in her hair and a scowl on her face. That scowl comes of having Mychel Redfort near, Alayne knew
"Your lordship," Mya informed Lord Robert, "Lady Waynwood’s banners have been seen an hour down the road. She will be here soon, with your cousin Harry. Will you want to greet them"
Why did she have to mention Harry. Alayne thought. We will never get Sweetrobin out of bed now. The boy slapped a pillow. "Send them away. I never asked them here." Mya looked nonplussed. No one in the Vale was better at handling a mule, but lordlings were another matter. "They were invited," she said uncertainly, "for the tourney. I don’t..." Alayne closed her book. "Thank you, Mya. Let me talk with Lord Robert, if you would." Relief plain on her face, Mya fled without another word.
"I hate that Harry," Sweetrobin said when she was gone. "He calls me cousin, but he’s just waiting for me to die so he can take the Eyrie. He thinks I don’t know, but I do."
"Your lordship should not believe such nonsense," Alayne said. "I’m sure Ser Harrold loves you well." And if the gods are good, he will love me too. Her tummy gave a little flutter.
"He doesn’t," Lord Robert insisted. "He wants my father’s castle, that’s all, so he pretends." The boy clutched the blanket to his pimply chest. "I don’t want you to marry him, Alayne. I am the Lord of the Eyrie, and I forbid it." He sounded as if he were about to cry. "You should marry me instead. We could sleep in the same bed every night, and you could read me stories."
No man can wed me so long as my dwarf husband still lives somewhere in this world. Queen Cersei had collected the head of a dozen dwarfs, Petyr claimed, but none were Tyrion’s. "Sweetrobin, you must not say such things. You are the Lord of the Eyrie and Defender of the Vale, and you must wed a highborn lady and father a son to sit in the High Hall of House Arryn after you are gone."'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end