$re = '/,?\s*(llc|Inc|co)\.?$/i';
$str = 'Burn To Ground, Groupwise, Ltd., People, Inc., SepiaShot
';
$subst = "";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;