re = /[0-9]{4}-(0[1-9]|1[0-2])-(0[1-9]|[1-2][0-9]|3[0-1]) (2[0-3]|[01][0-9]):[0-5][0-9]/
str = '2014-02-04 12:34'
# Print the match result
str.match(re) do |match|
puts match.to_s
end