$re = '/^[a-z-]+-\d{8}$/im';
$str = 'yellow-purse-65788544
big-yellow-purse-66784500
iphone-smart-case-water-resistant-55006610
iphone-smart-case-water-resistant-55006610999999999
iphone-smart-case-water-resistant-55';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);