$re = '/^(\w+) *= *(\w+) *; *.*$/';
$str = 'N_ame123 = Va23lue ; some comment';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);