const regex = /^((0?[1-9]|1[012])[- \/.](0?[1-9]|[12][0-9]|3[01])[- \/.](19|20)?[0-9]{2})*$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^((0?[1-9]|1[012])[- \\\/.](0?[1-9]|[12][0-9]|3[01])[- \\\/.](19|20)?[0-9]{2})*$', '')
const str = `12-11-2000`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}