import re
regex = re.compile(r"(?xm) (?(DEFINE) (?<byte> 2[0-4]\d | 25[0-5] | 1\d\d | [1-9]?\d) ) ^ (10 (?:\.(?&byte)){3} | 172 \. (?: 1 [6-9] | 2\d | 3[01] ) (?:\.(?&byte)){2} | 192 \. 168 (?:\.(?&byte)){2} | ) $")
test_str = ("10.0.0.0\n"
"10.1.2.3\n"
"10.255.255.255\n"
"172.16.0.0\n"
"172.25.1.2.3\n"
"172.31.255.255\n"
"12.34.56.78\n"
"123.456.789.0\n"
"192.168.0.555\n"
"192.168.0.0\n"
"192.168.1.2\n"
"192.168.255.255\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")