$re = '/\d+-\d+-\d+-\d+-\d/';
$str = '978-0-321-99278-9
978-0-321-99278
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);