package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^https:\/\/attacker.com\/((([a-zA-Z0-9\/])+)+)+$`)
var str = `https://attacker.com/auth/callbackaaaaaaaaaaaaaaaaaaaaa%`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}