re = /^(([0-9]+)\.([0-9]+)\.([0-9]+)(?:-([0-9A-Za-z-]+(?:\.[0-9A-Za-z-]+)*))?(?:\+[0-9A-Za-z-]+)?)\+([0-9]+)/m
str = '1.2.4-dev+21'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end