re = /^[A-Za-z0-9._%+\\-]+@[A-Za-z0-9.\\-]+\\.[A-Za-zhealth]{2,4}$/
str = 'test@test.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end