import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<!-- build-remove-start -->([^<]*(?:<(?!!-- build-remove-end -->)[^<]*)*)<!-- build-remove-end -->";
final String string = "<!DOCTYPE html>\n"
+ "<html lang=\"en\">\n"
+ "<head>\n"
+ " <meta charset=\"UTF-8\">\n"
+ " <title>Hello</title>\n"
+ " <!-- bower:css -->\n"
+ " <!-- endbower -->\n\n"
+ " <!-- inject:css -->\n"
+ " <!-- endinject -->\n"
+ "</head>\n"
+ "<body>\n"
+ "<h1>Hello World!</h1>\n\n"
+ "<!-- build-remove-start -->\n"
+ "<!-- bower:js -->\n"
+ "<script src=\"../bower_components/jquery/dist/jquery.js\"></script>\n"
+ "<!-- endbower -->\n"
+ "<!-- build-remove-end -->\n\n"
+ "<!-- inject:vendor:js -->\n"
+ "<!-- endinject -->\n\n\n"
+ "<!-- inject:js -->\n"
+ "<!-- endinject -->\n\n"
+ "<!-- inject:app:js -->\n"
+ "<!-- endinject -->\n"
+ "</body>\n"
+ "</html>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}