import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:.*?(\\w[^@\\s]*@[^@\\s]{2,}).*?|.+)$";
final String string = "Sample text for testing:\n"
+ "abcdefghijklmnopqrstuvwxyz ABCDEFGHIJKLMNOPQRSTUVWXYZ\n"
+ "0123456789 _+-.,!@#$%^&*();\\/|<>\"'\n"
+ "12345 -98.7 3.141 .6180 9,000 +42\n"
+ "555.123.4567 +1-(800)-555-2468\n"
+ "foo@demo.net bar.ba@test.co.uk\n"
+ "www.demo.com http://foo.co.uk/\n"
+ "http://regexr.com/foo.html?q=bar\n\n"
+ "This is a line with an email@person.com email address";
final String subst = "\\1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}