$re = '/<a(?: [^>]+)?>((?:(?!<\/?a[ >]).)*)<\/a>/';
$str = '<a href="www.google.com">welcome</a>';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);