$re = '/^[1-9][0-9]?$|^100$/';
$str = '13';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);