package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\d.\d{2})`)
var str = `var text = 'PAY VALUES TO SUM - WITHOU NOTHING: 0.00 13º WORD WORD: 0.00' +
text += 'PAY VALUES TO SUM - ADD. 50 YEARS: 0.00 WORD WORD WORD: 0.00';
text += 'PAY VALUES TO SUM - ADD. 70 YEARS: 0.00 WORD WORD WORD: 0.00';
text += 'PAY VALUES TO SUM - ADD. 80 YEARS: 0.00 WORD WORD WORD WORD WORD WORD WORD: 0.00';`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}