const regex = /(?<!\+)\b\d+\b/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!\\+)\\b\\d+\\b', 'g')
const str = `My number is +12 345 678. I have galaxy s3, its symbol 34abc.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}