import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "# Look for `Wild Draw Four` or simply `Wild`\n"
+ "# `W` stored in \\1, `D` and `F` stored in \\2 and \\3, respectively\n"
+ "(W)I\\ LD(?:\\ (D)raw\\ (F)our)?\n"
+ "|\n\n"
+ "# Look for `Draw Two` or `Draw Four`\n"
+ "# `D` stored in \\4, `T` or `F` stored in \\5\n"
+ "(D)raw\\ (?|(T)wo|(F)our)\n"
+ "|\n\n"
+ "# Look for the color and then the card type or number value\n"
+ "# `R`, `G`, `Y`, and `B` stored in \\6\n"
+ "# `S`, `R` or number value stored in \\7\n"
+ "(?:(?|(R)ed|(G)reen|(Y)ellow|(B)lue)\\ \n"
+ " (?|(S)kip\n"
+ " |(R)everse\n"
+ " |(\\d)\n"
+ " )\n"
+ ")";
final String string = "GIVEN:\n"
+ "Green 4 Green 4 Green 7 WI LD Green 9 Green 9 Red 3 Red 3 Red 4 WI LD Draw Four Red 5 Red Reverse Yellow 0 Yellow Skip Green 8 WI LD Draw Four\n\n"
+ "DESIRED:\n"
+ "G4 G4 G7 W G9 G9 R3 R3 R4 WDF R5 RR Y0 YS G8 WDF\n";
final String subst = "\\1\\2\\3\\4\\5\\6\\7";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}