$re = '/(?<!#)(promocode|promo code|promo|coupon code|code|coupon)/';
$str = 'promo #promo promocode codeproject';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);